Hi all,

 

Im kinda new here but im building the inmoov.

im trying to get the voice commands to work with inmoov.

i copy and paste the script from the site but he doesnt "hear" me i think.

when move the servo's manually thats no problem.

When i use the example robotlab script for pin 13 to turn him on or off.

That works perfect to my voice commands.

but when i use the inmoov script noting happens.

maybe someone can help me please? 

 

thank you all

gr Leon.

hairygael

10 years 6 months ago

Hi Leon.

From Holland?

Are you using the version 1695 with the inmoov script from the inmoov service page?

http://myrobotlab.org/service/inmoov

If not, it will not work properly at the moment , the recent versions of MRL can not work with the previous scripts like inmoov.full.py and minimal.py. And the new script of inmoov2.0 don't contain voice control commands yet, beside InMoovHand.PIRtriggered.py

http://myrobotlab.org/content/inmoov-20

Hope this helps

spaan14

10 years 6 months ago

Yes so im from the windy holland :)

 

i dubble checked it. i use 1695 and the good script.

everything works except the voice.

i did make a printscreen maybe you see the mistake i make.

 

it drive me crazy lol..and that at cristmas.  besides a good cristmas to all!!!!!

greets Leon

ricoldw

10 years 2 months ago

In reply to by spaan14

Sorry Guys.

 

For this time I will write in Dutch!

 

Ik heb hetzelfde probleem Leon, wat was jou oplossing?

Alles werkt behalve de voice control,

 

Groeten,

 

Rick (Aalten, Nederland)

GroG

10 years 6 months ago

Hello Spaan14.

I have a couple of suggestions after looking at your no-worky you posted.

1. You only have to load MRLComm.ino once on the Arduino(s) you are using for InMoov.  Once loaded - you do not need to load them again, unless you load some other Arduino program like "Blink"

2. If you do upload to your Arduino, it's usually best to restart MRL - there are problems around the RXTXLib which Arduino IDE and MRL both use to communication to the serial port.

3.  It doesnt look like from the no-worky you sent me that the InMoov full script was executed.  It looks like you manually start Sphinx.  You need Python or some other means to load Sphinx with the words you want recognized and the actions you want preformed.

hi Grog,

 

i did all above.

But i dont handstart sphinx. how do i put the words in to sphinx?

i just keep getting a python error at the bottom.

still wondering why my script isnnt fully executed.

i need a good mrl education lol.

i did send you a new no worky with the fingerstarter file maybe that will help 

(WOOPSSS sorry dont look at the latest noworky..i started the wrong version for this one..its getting late here lol sorry)

thanks so far. :) :) :) :)

 

Hi Grog,

i just found the problem. lol

in the fingerstarter script its missing the last line :  ear.startListening()

stupid of me that i missed that..

So now its all worky worky. me happy :p

thanks for your time.

Greetz Leon.

 

 

descobar

10 years 4 months ago

Hi Grog and Gael,

 

I've tried many times to repeat this same process and still no luck.

Where can I find the noworky button?  :( 

Its only for the hand that I am doing it for now and the thing is it doesnt hear me or move manualy, the servos move only when I plug in the power source ( 7.4v  battery and USB).

Help! pleaseee...

 

 

 

descobar

10 years 4 months ago

Hi Grog,

 

Thank you!

I'm happy to be here laugh

 

 

Please let me know if this helps

descobar

10 years 3 months ago

Hi Grog,

 

Not sure if you received the not worky, and if I did it properly.

I'm still not beign able to move the hand servos.

 

Thank you !

Hello Descobar - I recieved a no-worky from you Feb-25 .. Is that the last one you did?

If so it has a port in use error.  And I can see that you loaded the MRLComm.ino into the Arduino in the same session. This only has to be done once and once its done you should restart MRL.  

After its successfully upload, you won't need to upload again, unless you upgrade to InMoov 2.