Is tracking still working?

Having problems getting this working. Using the scripts on this site and elsewhere. Using 1412.

 

Trouble seens to be here.

# changing PID values change the 
# speed and "jumpyness" of the Servos
xpid = tracker.getXPID()
ypid = tracker.getYPID()
 
Here is what I see
 
------Traceback (most recent call last):  File string, line 25, in moduleAttributeError: org.myrobotlab.service.Tracking object has no attribute getXPID at org.python.core.Py.AttributeError(Py.java:205) at org.python.core.PyObject.noAttributeError(PyObject.java:1013) at org.python.core.PyObject.__getattr__(PyObject.java:1008) at org.python.pycode._pyx3.f$0(string:50) at org.python.pycode._pyx3.call_function(string) at org.python.core.PyTableCode.call(PyTableCode.java:167) at org.python.core.PyCode.call(PyCode.java:18) at org.python.core.Py.runCode(Py.java:1386) at org.python.core.Py.exec(Py.java:1430) at org.python.util.PythonInterpreter.exec(PythonInterpreter.java:267) at org.myrobotlab.service.Python$PIThread.run(Python.java:177)------
 

 

pscartozzi's picture

I have had some luck after

I have had some luck after browsing scripts on the net. Still not there but I did get it to track with about a 5-10 second lag. Maybe it is in the PID numbers. 

Any experiences would be appreciated and someone with a solid short test script woulld be a rock star.

Perry

 

moz4r's picture

Hi ! I have tracking working

Hi ! I have tracking working with the help of inmoov service and gael sources but it's slow ( I use intel core I3 ).

Im interested if you can increase speed of tracking. ( head or eyes )

You can check my script if can help you  :

sources : https://github.com/moz4r/aiml/tree/master/bots/BOTS-FRENCH/Inmoov_AI/PYTHON

complete package ( french ) : http://www.myai.cloud/Inmoov_IA_V17.zip 

pscartozzi's picture

Hello and thanks for the

Hello and thanks for the response. I'm looking over that link. Should I load the opencv file alone?