eclipse error

Hello everybody ,

i've updated the Git repository in eclipse, and since ,i get an error about jssc library.

Description Resource Path Location Type
Project 'myrobotlab' is missing required library: '/repo/com.googlecode.jssc/0.9.0/jssc.jar' myrobotlab Build path Build Path Problem
 
The library in my repo folder is the version 2.8.0 , not the 0.9.0 
 
So 
GroG's picture

BEETLE ! Nice to hear from

BEETLE !

Nice to hear from you !

do a git pull from the repo project ! :)   JSSC is a replacement for the rxtxLib.  Arduino IDE has dropped rxtxLib too now.

beetlejuice's picture

Hi, Yes, long time, i was

Hi,

Yes, long time, i was sick :-(

I've already did a pull of the repo, but i get only the version 2.8.0 of jssc . Eclipse request the version 0.9.

To be sure, i did a reset of the master and pulled again, but eclipse say the folder is up to date.

GroG's picture

Hope you are feeling better

Hope you are feeling better Beetle !

And you are Right !  .. Sorry I have been very busy working on API2 branch and forgot to branch the repo ..   0.9.0 is very old - the strange thing is - your branch "master" does not even use ANY version of JSSC !  

The new version of MRL (on API2 branch) DOES use it !!!

Fixed it just checked in the new version and set the classpath...  do a PULL !

Anyway - thanks for pointing it out .. Hope to see more videos of Sweety soon !

 

beetlejuice's picture

That work perfectly now I

That work perfectly now

I will soon make a video of Sweety using the kinect