1.0.44 [SOLVED]

this is what I get:

f:\mrl>java -jar myrobotlab.jar
starting bootstrap
110 INFO

Bootstrap starting spawn 20140814145544

110 INFO ============== args begin ==============

125 INFO jvmArgs []

125 INFO inArgs []

125 INFO ============== args end ==============

125 INFO protected domain /F:/mrl/myrobotlab.jar

1.0.43
125 INFO platform x86.64.windows

125 INFO total physical memory returned is -107

266 INFO update exists archiving current

313 INFO file myrobotlab.jar is locked - ejecting bootstrap.jar

Adding /org/myrobotlab/framework/Bootstrap.class
Adding /org/myrobotlab/framework/Platform.class
Adding /org/myrobotlab/framework/PreLogger.class
Adding /resource/version.txt
Adding completed OK
454 INFO bootstrap.jar spawning -> "C:\Program Files\Java\jre7\bin\java
.library.path="libraries/native/x86.64.windows" -cp ./;./myrobotlab.jar
ies/jar/* org.myrobotlab.service.Runtime -service gui GUIService

454 INFO PANIC - failed to create bootstrap - terminating - bye :(

501 INFO ------
java.io.IOException: Cannot run program ""C:\Program Files\Java\jre7\bi
-Djava.library.path="libraries/native/x86.64.windows" -cp ./;./myrobotl
libraries/jar/* org.myrobotlab.service.Runtime -service gui GUIService
Process error=87, The parameter is incorrect
        at java.lang.ProcessBuilder.start(Unknown Source)
        at org.myrobotlab.framework.Bootstrap.spawn(Bootstrap.java:265)
        at org.myrobotlab.framework.Bootstrap.main(Bootstrap.java:566)
Caused by: java.io.IOException: CreateProcess error=87, The parameter i
ct
        at java.lang.ProcessImpl.create(Native Method)
        at java.lang.ProcessImpl.<init>(Unknown Source)
        at java.lang.ProcessImpl.start(Unknown Source)
        ... 3 more
------

java.io.IOException: Stream closed
        at java.io.BufferedWriter.ensureOpen(Unknown Source)
        at java.io.BufferedWriter.write(Unknown Source)
        at java.io.Writer.write(Unknown Source)
        at org.myrobotlab.framework.PreLogger.write(PreLogger.java:72)
        at org.myrobotlab.framework.PreLogger.info(PreLogger.java:41)
        at org.myrobotlab.framework.PreLogger.error(PreLogger.java:53)
        at org.myrobotlab.framework.PreLogger.error(PreLogger.java:112)
        at org.myrobotlab.framework.Bootstrap.spawn(Bootstrap.java:284)
        at org.myrobotlab.framework.Bootstrap.main(Bootstrap.java:566)
leaving bootstrap

f:\mrl>

kwatters's picture

java path issue?

not sure if it's a copy and paste issue.. but it looks like the path to the java executable is cut off..

 

java.io.IOException: Cannot run program ""C:\Program Files\Java\jre7\bi

-Djava.library.path="libraries/native/x86.64.windows" -cp ./;./myrobotl

libraries/jar/* org.myrobotlab.service.Runtime -service gui GUIService

Process error=87, The parameter is incorrect

it should be  C:\Program Files\Java\jre7\bin\java.exe     

wvantoorn's picture

Maybe you should make mrl in

Maybe you should make mrl in c:

make a map in C: and there place the unpacked files there.

did you send noworky?

Mastablasta's picture

working

Thanks folks, got it to run. Deleted all old files and versions, re-install and all is good.

wvantoorn's picture

Hmmmm, so you made booboo,

Hmmmm, so you made booboo, ask help, make it worky yourself, and dont put it in top of topic?

maybe because you miss the german beer, wich i had last night!! Or you need sleep! Haha

 

but good to know what solution is, is it on windows 7 or 8